brew services --help
Jump to navigation
Jump to search
brew services --help
Usage: brew services [subcommand] Manage background services with macOS' launchctl(1) daemon manager. If sudo is passed, operate on /Library/LaunchDaemons (started at boot). Otherwise, operate on ~/Library/LaunchAgents (started at login). [sudo] brew services [list] (--json): List information about all managed services for the current user (or root). [sudo] brew services info (formula|--all|--json): List all managed services for the current user (or root). [sudo] brew services run (formula|--all): Run the service formula without registering to launch at login (or boot). [sudo] brew services start (formula|--all|--file=): Start the service formula immediately and register it to launch at login (or boot). [sudo] brew services stop (formula|--all): Stop the service formula immediately and unregister it from launching at login (or boot). [sudo] brew services kill (formula|--all): Stop the service formula immediately but keep it registered to launch at login (or boot). [sudo] brew services restart (formula|--all): Stop (if necessary) and start the service formula immediately and register it to launch at login (or boot). [sudo] brew services cleanup: Remove all unused services. --file Use the service file from this location to start the service. --all Run subcommand on all services. --json Output as JSON. -d, --debug Display any debugging information. -q, --quiet Make some output more quiet. -v, --verbose Make some output more verbose. -h, --help Show this message.
See also[edit]
brew services [ list | restart | info | start | stop ], homebrew.mxcl
brew
:update | upgrade | autoupdate
|install
|uninstall
|services
|list
,cask
|cleanup
|doctor
|test
|link
|unlink | changelog
|tap
|info
|search
|install --cask
|analytics off
|--prefix | --version
|brew --help ]
Advertising: